Difference between revisions of "Jouan C3i"

From London Hackspace Wiki
Jump to: navigation, search
m (Czechton moved page Big centrifuge to Centrifuge 10,000RPM without leaving a redirect)
Line 1: Line 1:
== Centrifuge from imperial ==
+
{{EquipmentInfobox
 
+
|name=Centrifuge 10,000RPM
 +
|image=Hackspace_Unknown.png
 +
|model=Jouan C3i
 +
|category=Equipment
 +
|subcat=Biohacking
 +
|status=Good working order
 +
|reqtraining=no
 +
|acnode=no
 +
|origin=Imperial College
 +
|location=Basement, Biohacking lab
 +
|maintainers=Biohackers
 +
}}
 
Currently broken. We'd like to fix it.
 
Currently broken. We'd like to fix it.
  

Revision as of 23:48, 26 April 2014

Centrifuge 10,000RPM
Hackspace Unknown.png
Model Jouan C3i
Sub-category Biohacking
Status Good working order
Last updated 15 December 2014 20:55:13
Training requirement no
ACnode no
Origin Imperial College
Location Basement, Biohacking lab
Maintainers Biohackers

Currently broken. We'd like to fix it.

Eugene had a look at it. What we know:

  • It switches on but won't spin
  • Motor is ok
  • Problem is with the electronics
  • Could be to do with the locking mechanism (machine thinks it's not locked when it is and hence won't start)
  • It's definitely not that, it went BANG! and blew the fuse

Andy had a look at it (2012/07/27): This appears to be the service manual for it: http://www.frankshospitalworkshop.com/equipment/documents/centrifuges/service_manuals/Jouan_CR3i_-_Service_manual.pdf

The tachometer works (at low speed), the microswitches on the lid interlock switch on and off and the control electronics and front panel seem to work.

There is a connection diagram for the main board on page 2-11 (page 20 in the pdf linked above). The motor drive is powered directly from the mains, separately to the rest of the main board.

Connector J12 (supplying mains power to the motor drive) is badly damaged and I have removed it. This is a three way Panduit brand IDT connector. I think it is an ITW Pancon brand MAS-CON 3.96mm connector (eg. http://uk.farnell.com/itw-pancon/ce156f22-3-d/wire-board-conn-female-3pos-3-96mm/dp/1418234).

The symptoms I've seen are consistent with the motor drive not getting any power (due to the damaged connector) or being otherwise broken (and hence damaging the connector).

I suggest:

  • Step 1: replace J12, either with the same type (if we can find a source) or with another 3.96mm connector of suitable specification.
  • Step 2: carefully test the motor drive circuitry.
  • Step 3: if the motor drive circuitry appears to work test the whole centrifuge.